Jumat, 05 Februari 2016

Bypass tanpa login

Cara Akses Website Tertentu Tanpa Login
Bukawinbox, klik “
IP > Hotspot
“
Klik tab “
Walled Garden
“
Klik tanda “
+
” untuk menambahkan.
isi website/situs pada kolom “
Dst.Host
” yang anda ingin user dapat mengakses tanpalogin.
Isi port “
Dst. Port
” jika anda ingin lebih spesifik hanya ke salah satu port.
Pilih “
allow
” dan OK.



Kamis, 04 Februari 2016

Mengatur bandwidth profile pada hotspot

1. Pastikan Anda telah menentukan user profile untuk masing-masing user. Disini saya membuat tiga user profile yang nantinya akan berbeda-beda dalam pembagian bandwidthnya.
- Bos = Upload 3 Mbps, Download 3 Mbps (3M/3M)
- Manajemen = Upload 512 Kbps, Download 1 Mbps (512k/1M)
- Karyawan = Upload 384 Kbps, Download 512 Kbps (384k/512k)
2. Masuk menu IP > Hotspot > User Profiles. Tambahkan profile baru (+) pada kolom name isikan nama profile yang akan digunakan, pada kolom Rate Limit (rx/tx) isikan bandwidth untuk masing-masing profile. OK
Mikrotik Hotspot User Profiles
Mikrotik Hotspot User Profiles
Setelah semua selesai, hasilnya kurang lebih seperti dibawah ini
Hotpsot User Profiles
User Profiles
3. Langkah selanjutnya adalah membuat user account untuk setiap client/orang. Masuk menu IP > Hotspot > Users. Tambahkan user baru (+) pada kolom name dan password merupakan username dan password yang digunakan untuk login pada jaringan hotspot. Pada kolom Profile arahkan pada user profiles yang telah dibuat tadi sesuai ketentuan. OK
Mikrotik Hotspot Users
Hotspot Users
Contoh beberapa user account yang telah dibuat sesuai user profilesnya masing-masing.
Hotspot User Account Mikrotik
Hotspot User Account
**Disini kita dapat menambahkan user hingga tak terbatas sesuai kapasitas Router Mikortik.
Demikian cara membagi bandwidth hotspot mikrotik, untuk manajemen bandwidth yang lebih advanced kita dapat menggunakan metode simple queue dan queue tree yang akan dibahas pada artikel selanjutnya. Semoga bermanfaat.

Mengubah halaman login hotspot Mikrotik

persiapkan dulu senjatanya :
> HTML editor : Dreamweaver, Notepad++, dll
> Picture editor : CorelDraw, Photoshop, dll

Pastikan Hotspot Mikrotik anda sudah jalan, coba akses halaman login hotspot anda di Browser.


Buka Winbox, masuk ke menu Files. Semua file halaman login hotspot ada di folder hotspot.


Agar bisa mengedit file nya, copy dulu file di folder hotspot itu ke komputer. Caranya bisa dengan mengakses file itu via FTP. Buka Windows Explorer, masukkan alamat berikut :ftp://ipaddressmikrotik, misalnya :ftp://192.168.100.1
Login dengan username dan password seperti pada winbox.


Masuk ke folder hotspot. Copy semua file nya, ctrl + a --> copy.


Kalo sudah tinggal edit aja file .html nya pakai Dreamweaver atau Notepad++. Untuk halaman login ada di file login.html.




Save file yang udah di edit itu, terus upload ke Mikrotik nya. Caranya sama seperti di atas, tinggal dibalik aja copy dari komputer ke mikrotik. Coba lihat hasil editannya. Buka halaman login Mikrotik nya, jadinya kaya gini :D

Gimana? masih membosankan tampilannya? Oke, gimana kalo diedit jadi seperti ini?


Keren ga? Itu halaman login hotspot Mikrotik yang saya pasang di kosan :D. Kalo anda ingin juga bikin halaman login seperti itu, silakan download aja contoh halaman login hotspot Mikrotik disini :
Terus edit aja file .html yang ada, misalnya login.html pakai Dreamweaver aja biar gampang.


Untuk gambar banner dan logo nya silakan anda cari atau buat sendiri pakai CorelDraw atau aplikasi lainnya. 

Blokir akses Internet melalui jalur wireless pd jam tertentu

Pertama, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL: ntp.kim.lipi.go.id (203.160.128.6) dan NTP Pool Project dengan salah satu URLnya: 0.id.pool.ntp.org (202.169.224.16). Untuk mensettingnya di MikroTik, ketikkan perintah berikut :


/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes

Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content="facebook" action=drop comment="Blokir Akses Facebook";

Via Winbox : 


Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :

Script untuk mematikan (disable) firewall :

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes

Via Winbox : 

Script untuk mengaktifkan (enable) firewall :

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

Via Winbox :

Script untuk disable firewall di hari libur dan enable di hari kerja :

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}

Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya :

Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :

/system scheduler add name="fb-08:00" start-date=jan/01/2010 start-time=08:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall pada jam istirahat (12:00) :

/system scheduler add name="fb-12:00" start-date=jan/01/2010 start-time=11:30:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mengaktifkan kembali (enable) firewall pada jam kerja (13:00) :

/system scheduler add name="fb-13:00" start-date=jan/01/2010 start-time=13:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall di luar jam kerja ke atas ( > 17:00) :

/system scheduler add name="fb-16:00" start-date=jan/01/2010 start-time=16:00:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :

/system scheduler add name="fb-sabtu-minggu" start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Sabtu. Dan parameter "interval" diberi nilai 7d.

Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :

/system scheduler add name="fb-senin" start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Senin. Dan parameter "interval" diberi nilai 7d.

Jumat, 20 November 2015

Blokir situs berdasarkan http

Install squid seperti biasa:
# apt-get install squid3
Edit /etc/squid3/squid.conf (perhatikan karakter yg di bold/tebalkan) menjadi:
#
# Recommended minimum configuration:
#

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines
acl lan-net src 192.168.1.0/24 #contoh jaringan LAN

acl SSL_ports port 443 # https
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

# ACL https yang mau di block
acl situs_https dstdomain .facebook.com

acl situs_https dstdomain .twitter.com

#
# Recommended minimum Access Permission configuration:
#
# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# Only allow cachemgr access from localhost
http_access allow localhost manager
http_access deny manager

# Block https access
http_access deny CONNECT situs_https

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost
#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost
http_access allow lan-net

# And finally deny all other access to this proxy
http_access deny all
# Squid normally listens to port 3128
http_port 3128
# Uncomment and adjust the following to add a disk cache directory.
cache_dir ufs /var/cache/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/cache/squid
#
# Add any of your own refresh_pattern entries above these.
#
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320
## squid konfigurasi end ##
Restart service squid:
/etc/init.d/squid3 restart
NOTE: cara ini hanya bisa berfungsi jika squid dijalankan dengan mode NON TRANSPARENT.
Jika ada yang bisa dengan mode TRANSPARENT tolong beritahu saya caranya.

Sabtu, 14 November 2015

blokir situs berdasarkan kata kunci

 
Linuxku.com sudah pernah memposting artikel mengenai cara mengaktifkan transparent web proxy di Mikrotik dan juga cara simpel memblokir situs di Mikrotik. Nah, pada kesempatan kali ini saya akan kembali memposting artikel yang masih ada kaitannya dengan kedua artikel tersebut, yaitu cara memblok situs berdasarkan kata kunci di Mikrotik.

Prinsip dari teknik ini adalah memblokir semua situs yang diakses ketika alamat url dari situs tersebut mengandung kata kunci yang kita berikan. Misalnya ketika kita sedang search kata kunci "porno" di wikipedia, maka otomatis wikipedia akan men-generate alamat url otomatis seperti berikut http://en.wikipedia.org/w/index.php?search=porno&title=Special%3ASearch&go=Go. Disitu terlihat ada kata "porno" yang terselip diantara url si wikipedianya, nah ketika muncul keadaan seperti ini maka mikrotik akan langsung memblokirnya.

Menarik? Untuk mengaktifkannya kalian tinggal mengarahkan ke menu IP > Web Proxy > Access > +

Kemudian atur menjadi :

Src. Address : 192.168.88.0/24
Path : *porno*
Action : deny

nb :
Src Address adalah klien yang ingin kalian blok.
Path adalah kata kunci yang ingin kalian blok.


Jika sudah klik Apply > OK.

Jangan lupa aktifkan transparent proxy untuk membelokkan paket HTTP ke Proxy. Lihat artikel ini jika kalian belum mengetahui caranya : http://www.linuxku.com/2013/09/Mengaktifkan-Transparent-Proxy-di-Mikrotik.html

Sekarang cobalah untuk mencari kata kunci porno pada web manapun (asal masih menggunakan protokol http), maka seharusnya Mikrotik akan langsung memblokirnya.


Blokir situs berdasarkan ip

Cara Mudah Blokir Situs Berdasarkan IP Address Tertentu Di mIkrotik

Dalam Tutorial Ini akan dibahas bagaimana memblok situs berdasarkan IP Tertentu. Dalam kasus ini missal kita akan memblok situs Facebook supaya tidak bisa diakses oleh salah satu client. Teknik ini merupakan penerapan firewall di mikrotik
Syarat
1.       Mikrotik Sudah Running Sebagai Router
2.       Familiar Dengan Aplikasi Winbox
3.       Seluruh Client Mikrotik Sudah bisa akses internet
Langkah –Langkah Pengaturan:
1.       Buat NAT Baru
·         IP - Firewall – NAT
·         Pada General Tab chain=srcnat,src.Addres = 192.168.1.0 pada Advanced Tab src.Addres List = Limited_web (tulis manual) pada Action tab Action = masquerade
2.       Masukan Situs Yang akan di Blokir
·         Klik IP – Firewall – Mangle
·         pada general tab chain = prerouting
pada advanced tab content = www.facebook.com
pada action tab action= add dst to addres list, addres list = deny
   
jika anda ingin menambahkan situs yang akan di blokir copy paste aja rule di atas dan ganti pada advanced tab Content isi dengan nama website yang akan di blokir
3.       Mengaktifkan Blokir yang Telah dibuat
·         IP – Firewall – Filter Rule
·         pada general tab chain = forward
pada advanced tab src addres list = limited web dst addres list = deny
pada action tab action = drop

Syntak diatas maksutnaya adalah kita memblokir semua situs yang kita beri judul deny hanya pada NAT limited_web
4.       Memasukkan daftar IP addres yang masuk dalam NAT Limited_web
·         ip - firewall - addres list
·         Klick add pada kiri atas gambar + merah name = limited web, addres = 192.168.1.12


sekarang ip 192.168.12  bisa konek ke internet tapi tidak bisa buka facebook
5.       Pengujian
Buka Browser di Client 192.168.1.12 selanjutnya buka situs Facebook, atau bias juga ping ke situs facebook. Ini hasilnya
Situs Facebook Tidak bias terbuka, Browser Terus Melakukan Connecting